Compiler Error Message:

Jun 13, 2012 at 9:37 PM

Hi!

I was trying to install this module on dnn 6.1.5 and I got the following error bellow

Do you think is way to fix that?

Thanks,

Wallace

Server Error in '/' Application.
Compilation Error
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: BC30201: Expression expected.

Source Error:


Line 8:          Public Shared Function ToggleFirstLetter(ByVal txt As String, ByVal upper As Boolean) As String
Line 9:              If upper Then
Line 10:                 Return txt.Substring(0, 1).ToUpper() +
Line 11:                        txt.Substring(1)
Line 12:             Else


Source File: C:\DotNetNuke\DNN613\Website\App_Code\NivoSlider\Utility.vb    Line: 10


Show Detailed Compiler Output:

Show Complete Compilation Source:

Coordinator
Jun 14, 2012 at 4:20 PM

Are you running .NET 4.0? I believe it is caused the the new line continuations for VB not being supported in .NET 3.5.

Jun 16, 2012 at 1:57 PM

Hello!

It fixed the problem and works real nice, also I try with DNN 6.2 and works.

Thanks for your Help.

Oct 11, 2012 at 9:27 PM
Edited Oct 11, 2012 at 9:28 PM

Upon install it threw me the same error working locally. Changed the AppPool from 2.0 to 4.0 and it fired right up. I wouldn't have thought that was the case, thanks for post guys. Works great.